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Introduction

AssetLabeler is a simple barcode asset label printing applic ation.
An asset is an item of property owned by a person or c ompany and regarded as having value.
An asset label has a unique number (and usually a barcode representing this number) and is
used to identify an asset in a database or spreadsheet 
The label will usually also have a title showing who the owner of the asset is.

A typical example:

AssetLabeler comes with some standard label designs for c ommon label sizes.
Labels can be printed on dedicated label printers that use rolls of blank labels, or on standard
laser printers using A4 sheets of labels.
You can choose to print to any printer that is installed on your Windows system .

Normally, an organisation would have one list of assets with sequential num bers. 
AssetLabeler records the next number to be used in a sequence so if you need to print the
next 50 labels for example, it knows where to begin to avoid duplic ating numbers.
If an organisation uses more than one sequence of numbers, perhaps for different
departments, AssetLabeler allows for this by keeping a list of Asset Label Types.

As well as the standard label formats that come with AssetLabeler, it also inc ludes a label
designer which allows you to design your own label of any size, change text sizes and fonts
and add other information. 
The label designer is very flexible but quite complex, so if you prefer, you can contact us at
Barcode Logic and we can help you with this or create the label form at for you.
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What's New

Version 1.0 18/04/2017

First release.
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Getting Started

Start the program either by clicking on the AssetLabeler icon on the desktop or from the
start menu (Barcode Logic / AssetLabeler).

When running the software for the first time, select Tools > Options from the main menu and
set the default label printer and other options you require. 
Next, from the menu, select Database > Asset Label Types to create one or more types. 
Finally Print Asset Labels.

The functions on the Tools menu will not normally need to be used.
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Using the PC Program

The Main Menu

The big button on the main window is for the most used function: Print Asset Labels.
This, and other functions are available on the menu at the top of the window.
The path and name of the current database file is displayed in the title bar.

The functions available from the main menu are:

File
Print Asset Labels

Database
Asset Label Types

Tools
Options

Import Custom Label Format File
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Edit Label Format Files
Open Label Format Files Folder

Select Database
Copy the Database File
Compact the Database File
Open Database Folder

Help
Contents

Register Software
Activate Software
Deactivate Software

About..
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File

Print Asset Labels

To print asset labels:

1. Select the Asset Label Type you want from the drop down list at the top. It will default to
the last one used.
The details of the label type will be displayed (Format, Title, Prefix, Nb Digits and the next
Number to be printed).

2. Enter the number of labels you want to print.
The formatted Asset number will be be displayed .. in this example, 5 labels From IT000004
to IT000008.

Optionally you can change the number to print. See Use a different number below.

3. Click on Print Labels. 

If the Preview Before Printing option is checked in Options then the labels will be displayed
on screen before giving you the option to print.
By default, the preview option is on. This allows you to see exac tly how your labels will look



Page9

AssetLabeler Us er Guide V1.0                                                                

© Barcode Logic Pty Ltd, 2017

as well as print multiple copies if required.

Note: It is very important that you use labels large enough to fit the barc ode, with some
white space either side of it, so it will scan properly. Using the preview function, you can test
this before buying any labels.

Here is an example of 40 x 28 mm continuous labels displayed in the preview sc reen:

Click on the printer icon at top left to print.

When printing on A4 sheets, you will be prompted to enter the start position of the label on
the page. This is so you can use partially used sheets. If you have used 5 labels from  a sheet,
the start position would be 6.

Here is an example of Avery type A4 labels (5 x 13 Matrix) labels displayed in the preview
screen:
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Click on the printer icon at top left to print.

4. Set the next number to be printed. After printing you will be asked if you want to set the
next number to be printed.
If the labels printed ok, then you would normally say Yes so you do not ac cidentally print
duplicates next time.
If the labels did not print correctly, throw them away, select No and try printing again.
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Use a different number or reprint a label.

Be very careful when using this function to avoid ac cidentally duplicating existing labels.

If you need to reprint one or more labels because they are damaged or missing for example,
you can print labels starting from a different number (different from the 'Next Number').
To do this, check the Use a different number box and enter the number you want to start
from.

Note that if the Use a different number box is checked, you will not be asked if you want
to set the Next Number and it will not be changed.
This is because you would normally want to continue the sequence where you left off and only
use this feature for reprinting.
If you ever do need to change the Next Number go to Asset Label Types, select the label
type, click on Edit and change it there.
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Database

Asset Label Types

To print asset labels, you must have created at least one Asset Label Type.

Click on Add to create an Asset Label Type, and fill in the details:

The available fields are these:

Description. This is only used to help you identify the asset label type. It is not printed on
the labels.

Format Filename. Each label format that is installed with AssetLabeler is held in a file. These
can be edited, or new ones added. Select the The required label format from the drop down
list.
All AssetLabeler format filenames begin with Label AL .

The sizes included by default are:

Continuous Media:
35 x 17 mm
40 x 19 mm
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50 x 25 mm
60 x 20 mm

A4 Sheets:
38.1 x 21.2 mm  (5 columns x 13 rows = 65 per page)
63.5 x 38.1 mm  (3 columns x 7 rows = 21 per page)
99.1 x 34.0 mm  (2 columns x 8 rows = 16 per page)

Title. This is usually printed at the top of the label. T his is optional.

Prefix. Often, Asset number begin with a prefix to help distinguish them from other asset
label sequences that may already be in use. This is optional, but rec ommended.

Number of Digits. This tells the system how many numeric digits, with leading zeros, are to
be printed after the prefix. Asset numbers are generally all the same length.

Next Number. This indicates which is the next number in the sequence to be printed. It is
important that no two asset number are the same, and this helps prevent duplic ates.
As labels are printed, this number is incremented. It is however possible to c hange this
number here, or override it during print ing.

With the example above, the labels will look like this:

The Title IT Department is printed at the top.
The Asset code has a prefix of IT, followed by 6 digits, and starting at the number 1, giving
the first one to be printed, the asset number of IT000001.
The label format file selected was Label AL 40mm x 19mm.fr3  which is for a roll of labels
with each label measuring 40mm x 19mm.
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Tools

Options

Select Tools / Options from the main menu to open this window.

Use the drop-down list to select the default Label Printer from the list of available printers
installed on the PC.

Preview Before Printing shows the labels on screen before sending to the printer so you
can see what is about to print and check for errors.

Allow Editing of Label Designs. This enables a main menu option (Tools >  Edit Label
Format files) which allows you to edit the design or size of the asset labels. The instruc tions
for doing this are outside the scope of this document as it is quite involved. If you want to
give it a go, the password is barcode, but if you need a different size, want fields added or
removed from the label or perhaps want a logo printed on it you may be better off c ontacting
your supplier or Barcode Logic.
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Import Custom Label Format File

If new label formats or sizes are added, this function can be used to add the label form at files
to those available to the system.
Once added, the new format will be available from the drop-down box when adding or editing
Asset Label Types.
When this option is selected a dialog will open allowing you to browse to the loc ation of the
new label format file.
Select the file and click on Open.
The file will be copied to the folder where all the label format files are stored.

The name of AssetLabeler label format files must be in this format: Label AL*.fr3
i.e. it must begin with Label AL and end with .fr3

We suggest you include the size of the label in the filename so it is easy to match with the
labels you are using, and perhaps a brief desc ription
e.g.

Label AL 100mm x 19mm with date.fr3
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Edit Label Format Files

The Edit Label Format Files menu option on the Tools menu will only be visible if it has
been enabled in Options (the password is barcode).

Select the label you want to edit from the drop down list at the top of the window.
When creating a new label, we suggest you base it on one of the existing labels that is closest
to the size you want to use (pick one with A4 in the nam e if you are to use A4 sheets).

So, select the label you want to edit from the drop down list  and click on the Edit Label
Design Button.
The selected label will be opened in the editor:
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If you are creating a new label, we suggest you immediately select File > Save As from the
menu at the top and give it a new name so it is easily identified and doesn't m ess up the
original.
Remember the filename must begin with Label AL and end with .fr3

e.g. Label AL 50mm x 25mm Freds New Label.fr3

We can't give you complete instructions here on how to use the editor, but here are som e key
points, and if you get stuck, give us a call (see Contact Barcode Logic).

1 This is the WYSIWYG layout of the label. Each 'object' on the label such as text or the
barcode can be resized and dragged around.
You can add objects (text, pictures etc.) to it using the icons on the left.
e.g. click on the A icon (Text object), then click the layout to drop it on, and enter the text

you want.
You can add fields from the item data from the list on the right by dragging them  on to the

layout (see 4).

You can click on any object to select it so you can change its properties (see 3).
You can Double click on objects to change some of their properties.
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2 This is a list of the 'objects' that comprise the label. You can click on one to select it so you

can change its properties (see 3).
Page1 is the label itself. Select this to change the width and height of the label.
Select the BarCode1 to select its properties.

3 This is a list of properties for the object that is currently selected.
The properties available depend on the type of object chosen (text, barcodes, pictures etc.).
The common ones you will change will be:
Height
Width
Font (including colour and size)
HAlign (Horizontal alignment - i.e. Left or right justified)
VAlign (Vertical alignment).
WordWrap (for text .. will it wrap over multiple lines).

Notes on the Barcode Properties. This is important and a complex subject but here are some
tips: 
BarType  This is important and a complex subject but here are some tips:
Some barcode types will only work with numeric codes and not alphanumeric.
If your codes are alphanumeric we recommend using setting the BarType to bcCode128B, in
fact even if they are numeric this is a good option.
The other options are spec ialised and not generally required.
WideBarRatio We recommend you do not change this.
Zoom We recommend you do not set this below 1

Important Tips:
1. Make sure there is 'whitespace' either side of the barcode. Generally this should be at least
5mm either side where nothing is print ed.
2. Print some test labels and make sure they scan easily and correctly with whatever sc anner
they will eventually be scanned with.

4 This is a list of the fields from the item database that you can drag onto the label ( System
Options).
There are actually only two .. the label title and asset barcode and these are already on the
standard label formats.

You can save the label format by selecting File > Save, or just close the editor and it will
prompt you to save it.

Now you can select the label format for an an Asset Label Type and preview or print them
using Print Asset Labels to be sure the data fits, that they look correct and m ost importantly ..
that they will scan correctly with a barcode scanner.
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Open Label Format Files Folder

This function will open the folder where the label form at files are stored in File Explorer.
This may be useful if you want to back up the files or c opy therm elsewhere.
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Select Database

By default, the database file used by the AssetLabeler system  is called AssetLabeler.mdb
and lives in the Windows Common Documents directory + \Barcode Logic\AssetLabeler.
On Windows 10 this is C:\Users\Public\Documents\Barcode Logic\AssetLabeler

If you need to find the database file, you can select Tools >  Open Database Folder from the
main menu and the folder will open in File Explorer.

You may want to move the database file to a server or other network location. You can also
copy and rename it for backup purposes.

To do this, use the Copy the Database File function.

This dialog will show you the location of the database c urrently in use.
Click on the button with the hand to select a new database.
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Copy the Database File

This function allows you to copy the current database file (and optionally renam e it).
You may want to do this to copy it for backup purposes or so it can be shared on a server or
network location.

When this function is selected, the standard Windows Save As dialog will open.
Select the new location and name (if you want to change it) for the database file and click on 
save.

Note that after this AssetLabeler is still using the original database.
If you want to use the one you have just saved, use the Select Database Function.

The path and name of the current database in use is displayed in the title bar at the top of
the main window.
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Compact the Database File

This function can repair most errors in the unlikely even that the database file has been
corrupted. 
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Open Database Folder

By default, the database file used by the AssetLabeler system  is called AssetLabeler.mdb
and lives in the Windows Common Documents directory + \Barcode Logic\AssetLabeler.
On Windows 10 this is C:\Users\Public\Documents\Barcode Logic\AssetLabeler

This function will open the folder where the database file is stored in file Explorer.

 



Page24

AssetLabeler Us er Guide V1.0                                                                

© Barcode Logic Pty Ltd, 2017

Help

Register Software

The AssetLabeler software will run in 'Demo Mode' for 3 days before requiring purchase and
registration.
After this a dialog will appear explaining that most features have been disabled: 

If you want to continue using the software, please purchase from  Barcode Logic then select
Help / Register Software from the main menu.
This window will appear:
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Please fill in the registration form and follow the instruc tions on screen.
An activation code will be sent to you. 
When received, select Help / Activate Software from the main menu, enter the supplied
activation code and the software will be unlocked.  

The software licence is 'tied' to the PC it is installed on. If you need to m ove the license to
another PC, please select Deactivate Software and contact Barcode Logic with the 'remove
code'.
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Activate Software

When you have received you activation code, type (or cut and paste) it into the text box:

Press OK. If entered correctly, and the code is valid it will display:
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Deactivate Software

If you want to deactivate the software to m ove your license to another PC, select this
function.
You will be asked (twice) to confirm that this is what your really want to do, as once this is
done, the software will stop working.

If you confirm, this window will appear:

Now you can either email, print and fax or phone in the Remove code to Barcode Logic which
will allow the software to be re-registered on another PC.
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Support

Your first line of support will be the organisation you purc hased this system from.

Should they be unable to help, please email any questions/suggestions to:

support@barcodelogic.com.au
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Contact Barcode Logic

If you have any problems or queries with this software or would like to request c hanges or
additions, please
contact us.

Barcode Logic Pty Ltd
P.O.Box 6161
West Gosford
NSW 2250

EMail: info@barcodelogic.com.au
Web: www.barcodelogic.com.au

The BarPrint software and this help file are (c) Copyright Barc ode Logic Pty Ltd 1999-2017



Page30

AssetLabeler Us er Guide V1.0                                                                

© Barcode Logic Pty Ltd, 2017

Index

 - A -
Activate Software  26
Add an Item
Asset Label Types  12

- C -
Compact the Database File  22
Contact Barcode Logic  29
Copy the Database File  21

- D -
Deactivate Software  27
Default File Paths

- E -
Edit Label Format Files  16

- G -
Getting Started  5

- I -
Import Asset Information From File
Import Custom Label Format File  15
Introduction  3

- O -
Open Database Folder  23
Open Label Format Files Folder  19
Options  14

- P -
Print Asset Labels  8
Programming the PDT

- R -
Register Software  24

- S -
Select Database  20
Support  28
System Options

- T -
The Main Menu  6

- W -
What's New  4


	Table of Contents
	Introduction
	What's New
	Getting Started
	Using the PC Program
	The Main Menu
	File
	Print Asset Labels

	Database
	Asset Label Types

	Tools
	Options
	Import Custom Label Format File
	Edit Label Format Files
	Open Label Format Files Folder
	Select Database
	Copy the Database File
	Compact the Database File
	Open Database Folder

	Help
	Register Software
	Activate Software
	Deactivate Software


	Support
	Contact Barcode Logic

