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Introduction

This Imprest System (Imprest3) has been designed to remove some of the effort involved and
improve the accuracy of restocking consumables in stores on wards (Sub-inventories or
Imprest Locations).

The list of items that should be stored in each Imprest Location is transferred from Oracle to
the Imprest system installed on the PC, and from there to a Mobile Computer (Scanner).
Location and Item barcodes may be printed from the system and attached to the appropriate
locations (shelves/bins etc.) within the Imprest.

When an Imprest needs restocking, the Imprest location barcode is scanned, then each item
barcode is scanned and the quantity required for the item is entered.

This information is later uploaded back to the PC, and from there into Oracle, which will
generate a requisition for picking at the warehouse.

The system consists of scanner and desktop applications for Windows 10 based PC's. 

Data is transferred between Oracle and the Imprest system PC using FTP (File Transfer
Protocol). See Oracle Interfaces.

Data is transferred between the scanner and PC using a USB cable connected to the scanner
dock (aka cradle).
The scanner must be in the dock when sending and receiving data. 
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What's New

Ver 1.2.0 19/07/2022

1. Fixed bug in where Android write permissions were not correctly granted.
2. Fixed bug one too many icons were installed on the scanner.

Ver 1.1.0 02/05/2022

1. Converted to use the Skorpio X5 scanner with Android 10 and USB communications.

Ver 1.0.0 16/04/2020

1. First release.
This version was created for Datalogic Android Mobile Computers (specifically the Memor 1)
and was based on the ImprestCE2 system Ver 2.1.0.
It uses Wi-Fi for data transfer instead of the USB connections used by previous versions of the
system.
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Installation and Setup

Installation

This document covers the installation and operation of the Imprest3 system on a desktop PC.

For it to operate, it needs to receive item and location data from Oracle (at least daily), and
send order data back to Oracle.
How this is set up is outside the scope of this document, and the responsibility of the LHD IT
department, see Oracle Interfaces for a brief explanation of what is required.

To get up and running quickly, this is what you need to do:

Install the Imprest3 software on your PC by running the Imprest3_V1_1_0_Setup.exe
file.

Run Imprest3 from the Start Menu (you will find it under Barcode Logic) or desktop icon.

Go to Tools / Options on the main menu and change the settings as required.

Now check the settings on the scanner.
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The default settings should be ok for normal operation and not need changing.

Tap on the menu icon at top left of the main menu:

Select Settings.

You will need a password to access these settings.

Return to the main menu on the scanner.

Now you are ready to scan items.
See Basic Operation.
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Oracle Interfaces

1. Item and Label data from Oracle.

An Oracle user runs an IF1063 report in Oracle which creates a file called labels.txt and
sends it to an FTP Server.
The IP Address of the FTP Server and the Employee number of the Oracle operator must be
supplied to FMIS at eHealth NSW who will configure the system.
Which FTP server the file is sent to depends on which user runs the report.

The Imprest system must be told the location where the file is sent in Options (Tools >
Options > File Paths > Item Import).

It is up to the LHD whether:

Each Imprest system PC has an FTP Server enabled so an operator can run the IF1063 report
and the labels.txt file is generated and sent directly to that PC.
or 
The IF1063 is run centrally (perhaps once each morning, or on request) and each Imprest
system is configured to import the file from a shared folder on a server.

2. Order data to Oracle.

After Load Imprest Data From Scanner To Oracle has been run, the order data is written to a
file called stores.txt in the location specified in Options (Tools > Options > File Paths >
Imprest Export).
This file must be transmitted to Oracle for processing using the Oracle IF1035 interface.
This can be done in one of two ways:

By running the Oracle R12 Barcode Transfer Script from an icon on the desktop 
or
Using the Automatically send Imprest Data to Oracle function.

Both these rename the file and send it to an FTP Server.
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Basic Operation

To validate the barcodes you are scanning (and reject them if not in the list), it is important
that the data is up to date.
Click on Refresh PC Imprest Data From Oracle on the PC. This will import the labels file from
Oracle into the local database so labels can be printed.
This will also import the Out of Stock Items list if this is being used.

Now place the scanner in the dock and select Copy Imprest Data to Scanner to transfer the
data to the scanner.

You are now ready to scan items.

Select Scan Imprest on the scanner.
Scan a location barcode then scan each item to be ordered in turn and enter the order
quantity.
Repeat for other locations until finished.

Now place the scanner back in the dock and select Load Imprest Data from Scanner to Oracle
to transfer the data from the scanner and send it to the Oracle FTP server where you can
select it to create requisitions.
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Using the PC Program

The Main Menu

There are buttons on the main window for the most frequently used functions.
Some others are also available on the menu at the top.

Imprest
Refresh PC Imprest Data From Oracle
Copy Imprest Data To Scanner
Load Imprest Data From Scanner To Oracle

Enquiries and Labels
Items
Locations
Out of stock Items

Reports
Units Ordered by Item
Units Ordered by Location
Units Ordered (All Locations)
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File
Re-Import Imprest Data - Reprocesses a file previously uploaded from a scanner. Only

to be used under instruction in an emergency.
Resend Imprest Data to Oracle - Resends a file previously sent to Oracle via FTP.  Only

to be used under instruction in an emergency.

Tools
Options
FTP Server Options

Copy the Scanner Program to FTP Server
Import Scanner Licence file and copy to the Scanner

Delete All Pick Data more than 60 Days Old - clears old data out of the database just
to keep the size down.

Delete All Archived Data Files - clears old backup files from the PC to free up disk
space.

Error Log File - Shows any errors that may have occurred during Refresh PC Imprest
Data From Oracle function. 

Folders - These functions shouldn't normally be required, but they allow you to easily
open the folders that the application uses in File Explorer and may be helpful for technical
support.

Update Inventory Item Flag from CSV File

Import Custom Label Format File - if a special label format has been created, this
function is used to import it into the system.

List USB Connected Scanners
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Refresh PC Imprest Data From Oracle

A file called labels.txt which contains the Imprest Data (locations, items, min and max
quantities etc.) is created by Oracle when the IF1063 Barcode Logic Outbound Interface
report is run.
For this file to be created and sent to your Imprest System PC, Oracle needs to be configured
with your employee number and the IP Address of the PC.

Optionally a file called OutOfStockItems.txt containing a list of out of stock items and
suggested substitutes is created by the Barcode Logic Imprest Out of Stock Items
application.
This file, if one exists, is also imported by this function. Set the Out of Stock Import Path
in Options to the location of this file.

The Imprest system uses a local database on the PC.
The database holds the list of Imprest Locations and the Items that should be held in each of
these Imprests.
This information is imported into the database from the labels.txt file using this Refresh
function and can be run at any time, and preferably once a day.

If an out of stock items file exists (OutOfStockItems.txt), this will also be imported.

A window will show the progress of the file import:

Item records in the database but no longer in the import file will be deleted.
If any errors occur, the details of the errors are recorded in the log file (see Tools > Error Log
File >  View Error Log from the main menu).

If any new records are added, or the details of any item have changed (description, issue
unit, min or max quantity) it is likely that new barcode labels will need to be printed for
these.
The 'Last Updated' date and time for these items in the database will be changed to the
current date and time to allow them to be easily found in the database. See Items.  
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After the file has been imported, files will be created for the scanner(s) and sent to the
Scanner FTP Server (see FTP Options) so the scanners can upload them by selecting Receive
Item List.

Technical Information:

The item/location import file is called labels.txt.
The file is created from data exported from Oracle when the IF1063 Barcode Logic
Outbound Interface report is run.

The file must be located in the Item Import file path as specified in Tools / Options.

The file has one item record per line, and is pipe | delimited. 

A sample of part of a file looks like this:

|190-EMERGENCY|520178|ADAPTOR, CATHETER TO LUER SYRINGE, FOLEY, URINARY, DISPOSABLE|EACH|1|3|

|190-EMERGENCY|520198|ADHESIVE TAPE, SURGICAL, HYPOALLERGENIC, MICROPOROUS, 2.5CM X 9M,

PAPER|EACH|6|12|

|190-EMERGENCY|520287|BANDAGE, CONFORMING, GAUZE, ELASTIC, RETENTION, 2.5CM X 1.5M, NON

STERILE|PACK OF 12|0|0|

|190-EMERGENCY|520291|BANDAGE, CREPE, HEAVY WEIGHT, 10CM X 1.5M, STERILE|PACK OF 12|12|24|

|190-EMERGENCY|520292|BANDAGE, CREPE, HEAVY WEIGHT, 15CM X 1.5M, STERILE|EACH|12|12|

|190-EMERGENCY|520304|BANDAGE, TUBULAR, RETENTION, MEDIUM LIMB|EACH|1|1|

|190-EMERGENCY|520341|CANNULA, INTRAVENOUS, 18FG X 30MM|EACH|20|50|

|190-EMERGENCY|520991|CANNULA, INTRAVENOUS, 24g x 19mm, TERUMO|EACH|100|200|

|216-GRACE|500049|ADHESIVE TAPE, SURGICAL, HYPOALLERGENIC, MICROPOROUS, 1.2CM X 9M,

PAPER|EACH|0|24|

|216-GRACE|500064|ADHESIVE TAPE, SURGICAL, NON STRETCH, 1.2CM X 9M, ZINC OXIDE, TAN|EACH|24|48|

|216-GRACE|500151|APPLICATOR, DISPOSABLE, COTTON TIP, DOUBLE ENDED, 7.5CM, PLASTIC, NON

STERILE|PACK OF 50|1200|3600|

|216-GRACE|500318|BANDAGE, RETENTION, COHESIVE, ELASTIC, 5CM X 2M, NON STERILE|EACH|18|54|

|216-GRACE|500458|BLADE, STITCH CUTTER, STERILE, DISPOSABLE|EACH|25|100|

|216-GRACE|500750|CANNULA, INTRAVENOUS, 24G X 19MM|EACH|10|30|

|216-GRACE|500752|CANNULA, INTRAVENOUS, NEEDLELESS SYSTEM, BLUNT, SYRINGE, 18G, STERILE|BOX OF

100|1|1|

The Fields in each record are (and the maximum length of the field):
        Location Code - Used in the Location Barcode (20)
        Item Code - Used in the Item Barcode (20)
        Item Description (120)
        Issue Unit (Unit of Measure) (25)
        Minimum stock Level (10)
        Maximum stock level (10)

The same item may appear in different locations with different m inimum and maximum stock
levels.

This data is now stored in the local database and can be viewed, and labels printed, using the 
Items and Locations enquiry buttons.
The data can also be copied to a scanner so it is displayed when items are scanned. 

The 'Inventory Item' field will be set to True for all items until the Update Inventory Item Flag
from CSV File function is run.

The labels.txt file also contains a dummy location called ALL_LHD_ITEMS which will have all
the items that are valid for the entire LHD.
This allows any valid item to be ordered even if it is not assigned to the current Imprest
location (sub-inventory), but these cannot be viewed on the PC or labels printed for them.
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The out of stock items file is called OutOfStockItems.txt 
This file is created by the Barcode Logic Imprest Out of Stock Items application.

The file must be located in the Item Import directory as specified in Tools / Options on the
main menu.

The file has one item record per line, and is pipe | delimited. 

A sample of part of a file looks like this (test data only):

|500045|15012020|16022020|Y|503968|ADMINISTRATION SET, INTRAVENOUS, WINGED, NEEDLE, 25G, SCALP

VEIN|EACH|1|9|

|500058|15012020|16022020|N||||0|9999|

|500064|15012020|16022020|Y|503971|ADMINISTRATION SET, INTRAVENOUS, WITH CLEAR LINK, NEEDLELESS

ACCESS, SOLUTION|EACH|100|200|

|500214|15012020|16022020|Y|503987|APPLICATOR, BRUSH, DENTAL, SUCTION, SWAB|EACH|1|2|

|500245|15012020|16032020|N||||0|9999|

The Fields in each record are (and the maximum length of the field):
        Out of Stock Item Code - The Item Barcode (20)
        Start Date (ddmmyyyy format) - The first day the item is out of stock        
        End Date (ddmmyyyy format) - The first day the item is out of stock
        Has a substitute (Y or N) - Does this item have a substitute,         
        Substitute Item Code - The substitute Item Barcode (20)
        Substitute Item Description - (120)
        Substitute Item Issue Unit (Unit of Measure) (25)
        Substitute Item Minimum stock Level (10)
        Substitute Item Maximum stock level (10)

After Import to the database, files are created in a text format suitable for the scanner (fixed
length fields).
These files are called Imprest3_Download.txt and Imprest3_OutOfStockItems.txt
They are created in the C:\Users\Public\Documents\Barcode Logic\Imprest3 folder.
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Items

This function displays the list of items in the local database that have been imported from
Oracle using the Refresh PC Imprest Data From Oracle function.

From this list it is possible to print the item barcode labels.
The default labels are 100mm x 19mm in size and look similar to this:

The label format used can be changed in the drop down list called Item Label Format
Filename in Options.

By default the grid will list all the items in the database for all locations.
Labels can be printed for all items in the grid or just the item currently selected.
You can select one item by clicking on it or select multiple items using the Ctrl and Shift keys
in the standard Windows manner.

The number of items in the grid can be reduced by these methods:
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1. Clicking on the Show Items by Location button will allow you to select from a list of the
available locations in the database. All the items for the selected location will be displayed.
2. Click on the Filter button to select items that match a certain field value or range. Try the
filter to see how it works. To redisplay all the items, click on Show All Items.

Using Show Location By Item, you can select any item and the grid will display all the
locations that contain that item.

Print Report of All Items Listed will allow you to print out the details of all the items
currently displayed in the grid on a report printer.

Last Updated shows the last time the record was changed, or when it was added. This is
useful for printing labels for items that have changed since a particular date.
Use the filter button to select a range of dates to display only those records.

Inventory Item shows whether the item is a Stock (Inventory) or Non-Stock (supplier) item.
By default these are set to true (Inventory or Stock).
These are only changed by using the Update Inventory Item Flag from CSV File function as
this information is not available in the standard imprest data file from Oracle (labels.txt).
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Locations

This function displays the list of unique locations in the local database that have been
imported from Oracle using the Refresh PC Imprest Data From Oracle function.

From this list it is possible to print the location barcode labels.
The default labels are 100mm x 19mm  in size and look similar to this:

The label format used can be changed in the drop down list called Location Label Format
Filename in Options.

By default the grid will list all the locations in the database.
Labels can be printed for all locations in the grid or just the location currently selected.
You can select one location by clicking on it or select multiple items using the Ctrl and Shift
keys in the standard Windows manner.

The number of locations in the grid can be reduced by clicking on the Filter button to select
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location codes that match a certain field value or range. To redisplay all the locations, click
on Show All Locations.
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Out of Stock Items

This function displays the list of out of stock items in the local database (if there are any) that
have been imported using the Refresh PC Imprest Data From Oracle function.
This is just for informational purposes, and this data cannot be changed.

The start and end dates are inclusive. i.e. The item is out of stock from the start to the end
date, including all of the start date and end date.

If an item is out of stock when scanned and has no substitute, you will be told, and you will
not be able to order the item.
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If it is out of stock but there is a suggested substitute, you will be asked if you want to order
this item instead.

Note that the min and max quantities of out of stock items are the same for all locations.
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Copy Imprest Data To Scanner

When scanning an Imprest, it is recommended that the location and item barcodes scanned
will be validated against the data received from Oracle.
This is optional however, and validation can be enabled or disabled in Options on the scanner
(see System Functions / Options).

If you are validating data, then after the PC Imprest Data has been refreshed, it should be
copied to the scanner so that it is up to date.

To copy the data, the scanner must be connected to the PC.
Place the scanner in its dock.
The scanner will make a distinctive noise to indicate it has connected ok.

Important: The scanner program must be at the main menu for the data file to upload
successfully. 

When connected, click on the Copy Imprest Data to Scanner button on the main screen of
the PC.

The data will be copied to the scanner

When complete, it will let you know ..

The scanner is now ready for use.
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Tools
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Options

After the system is first installed, and before it can be used, some configuration of the system
is required.

Start the program either by clicking on the Imprest System 3 icon on the desktop, from the
start menu (Start > Barcode Logic > Imprest System 3).

Select Tools from the main menu, then Options to display this dialog box.

The critical options that must be correct for the system to work are the Organisation ID and
File Paths.

General

Organisation ID
This code is returned to Oracle in the file of collected data (Stores.txt), so it knows which
organisation the order was received from.

On upload from scanner, warn if the item has been ordered in the last nn hours. 
(Default is not checked)
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This option is here to reduce over-ordering. 
If this option is checked, and unknown to you, someone has already scanned an Imprest in
the previous nn hours (which defaults to 48 hours but can be changed to whatever you like),
then you will be warned when you Process Scanner Data and have the option not to order the
item again.

Automatically send Imprest Data to Oracle after upload from Scanner
This sends the stores.txt (Imprest stores requisition file) to the Oracle FTP server without
having to the use the R12 transfer script.

Printing

The report and label printers can be selected from drop down lists that will show the printers
currently installed on the PC.
The report printer must take A4 paper.
The label printer would normally be a dedicated label printer which uses rolls of labels.

There are standard default Location Label Format and Item Label Format filenames, and
these would not normally be changed, however a couple of other formats are available in the
drop-down lists including an A4 sheet option.
If the label size you want is not available in the lists, we are able to create special label
formats on request. 

Preview Before Printing
If this box is checked, you can view the labels or reports on screen before printing. Default is
checked. 

Allow Editing of Label Designs
This is an IT department function and should not be needed on site. 

Note: If you install a printer while the Imprest software on the PC is running, it will not
appear in the drop down lists until the program is closed and restarted.

File Paths

The path (folder) options can be changed by clicking on the buttons with the hand and
selecting the required path.
These should only need to be set at installation time. Changing these options after the system
is installed and tested may stop it working correctly.

Item Import
Oracle can export a file containing information on the items that should be stored in each
imprest for a particular organisation.
This information can be imported into the local database for label printing, reporting and
validation of the scanned items using the Refresh PC Imprest Data from Oracle function.
This should be set to the path (folder) where Oracle places the exported file.
The file is called labels.txt.
See also Oracle Interfaces

Out of Stock Item Import
A file containing a list of out of stock items and suggested substitutes can be created by the
Barcode Logic Imprest Out of Stock Items application.
This should be set to the path (folder) where this application places the exported file.
The file is called OutOfStockItems.txt.
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Imprest Export
This is the path (folder) where the collected imprest data is placed after scanning with the
scanner and uploading to the PC. 
The file is called stores.txt and is sent to the Oracle FTP Server for processing. 
See also Oracle Interfaces
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FTP Server Options

These parameters are required to transfer order data to Oracle.
There are set to the default settings for NSW Health and should not need changing.
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Copy Scanner Program to the Scanner

The scanner will already be programmed and running when supplied by Barcode Logic or one
of its distributors, if however it needs reprogramming, perhaps because a new version of the
software has been released, please follow these steps:

Install the new version of the software on the PC, then select this function.
The latest version app package file will be copied to the connected scanner.

The scanner can then import and install the file using the Update Program function from
the Scanner System Menu.

Note: You can only program a scanner that has had Imporest3 installed on it previously by
Barcode Logic.  
This function is only for upgrading an existing Imporest3 scanner and cannot be used to
program a new device.
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Import Scanner Licence file and copy to the Scanner

For copy protection purposes, each scanner requires a licence file for the app to run.
The licence file name is based on the application name and serial number of your scanner e.g.
Imprest3_G19P12345.lic

The scanner should come with the app and licence file already installed but if for any reason it
is lost or requires reinstalling, Barcode Logic will supply one.

Select this function and browse to wherever on your PC you have saved the licence file.
This defaults to the Item Import folder specified  in Options.
The file will be copied to the connected scanner.
If more than one scanner is connected, it will ask you which one you want to copy it to.
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Update Inventory Item Flag from CSV File

This function is optional and normally it is not required.

The Inventory Item field shown in the Items grid indicates whether an item is Stock
(Inventory) or Non-Stock (Supplier).
This information is not available in the standard imprest data file from Oracle (labels.txt) so
to update this field it is necessary to run another Oracle report and import the data.

Please follow these steps:

1. In Oracle, run the report to produce an NSWH Imprest Count Sheet for the Sub
Inventories required.
It will produce an Excel file (.xlsb format). 
Open this file in Excel. It should liook similar to this:

To import this file we need to save it in .CSV format.
There may be a warning at the top saying PROTECTED VIEW. click on the button labeled 
Enable Editing.
Now from the menu, select File and Save as.
Browse to a folder that you can find later. I suggest using the Item Import folder specified in
Tools > Options. 
From the Save as type: drop down list, select CSV (MS-DOS) (*.csv).
finally click in Save.
 
Ok. Now go back to the Imprest System program and from the menu select Tools > Update
Inventory Item Flag from CSV File
Browse to where you saved the file and select it.
The program will read through the file and process each record in turn.
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If a Sub-Inventory / Item record is found, the Inventory Item flag in the Items list will be
set to True if the Source Type is Inventory and false otherwise. 

When complete, it will show how many records were updated, or were not found.

 The Inventory Item flag in the Items list will be checked or not, depending on whether an
item is Stock (Inventory) or Non-Stock (Supplier).
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Folders

These functions shouldn't normally be required, but they allow you to easily open the folders
that the application uses in File Explorer and may be helpful in locating your import and
export files.
The options are:

Items Import Folder - As specified in Tools > Options > File Paths > Item Import
This is where the labels.txt file should be. This is imported by the Refresh PC Imprest Data
From Oracle function.

Out of Stock Items Import Folder - As specified in Tools > Options > File Paths > Out of
Stock Item Import 
This is where the OutOfStockItems.txt file should be. This are imported by the Refresh PC
Imprest Data From Oracle function.

Export Folder - As specified in Tools > Options > Scanner Data Export File > Export File Path
The stores.txt file containing order data that is sent back to Oracle is created. See Process
Scanner Data.

Data Folder - C:\Users\Public\Documents\Barcode Logic\Imprest3
The location for the MS Access database (Imprest3.mdb), the Imprest3.ini settings file, label
format files and other data files used by the system.

Scanner App Folder - C:\ProgramData\Barcode Logic\Imprest3
The scanner application is stored here (Android .apk file). See Copy Scanner Program to FTP
Server.
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List USB Connected Scanners

To see which scanners are connected via USB, run this function.
It will show the manufacturer, model and serial number.

N.B. The serial number may be different from the one printed on your device as it is an
internal number, but will be unique.
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Using The Scanner

General Operation

As this system uses a standard version of the Android operating system, operating it should
be familiar to anyone who uses an Android phone.

Along the bottom is the main Android menu

The Back Button will take you back to a previous step (an edit control or the previous page).
If you keep pressing the back button, you will eventually return to the main menu.

The Home button will minimise all apps and show the desktop

The Overview button will show all recently opened apps so you can select one, or remove it
from the list by swiping.

The physical Power button on the left hand side allows you to Power off or Restart the
device.

To run your Barcode Logic application, tap on the Overview button, and if it is in the list,
select it.
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If not, then tap on the Home button and swipe up on the desktop to display icons for all the
apps installed.
Find the Barcode Logic app. and tap on it.

At the top of some pages in the app, you may see this menu icon:

Tap on it to see more options.

The barcode scanner is enabled whenever barcode data entry is required.
Press the scan button to activate it.

To manually type a barcode number or other data, tap on the edit field and the on-screen
keyboard will pop up.
When the keyboard is displayed, the Back button changes to a down arrow:

Tap on this to close the keyboard.
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Scanner Main Menu

To select an option from the main menu, tap on it.

The options are:

Scan Imprest

At top right, the icon with three  dots will display the Scanner System Menu when you tap on
it.
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Scanner System Menu

Tap on the menu icon  on the main menu to display the System Menu.

The available options are:

Settings

This has some configuration options for the app. See Settings for more details.

Update Program

If a new version of the app exists, and has been sent to the scanner using the Copy Scanner
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Program to the Scanner function in the PC app, this will attempt to install it.
It is recommend that you send any data on the scanner and process it on the PC before
installing a new version, as existing data may not be compatible with the new version.

If for some reason the app fails to install (you get an App Not Installed error), it may be
necessary to uninstall the app first.
Please follow these steps:

Make a note of the Settings in the current version, as these will be lost after installing.
Hit the Home button to show the desktop.
Open the Android Settings app (tap on the Gear Icon).
Go to Apps & Notifications, find the app to uninstall, tap on it and Uninstall.

Now open the Files app (Hit the Home button, swipe up and tap on the Files icon.
Browse to the Download folder. 
In there you should see an apk file (application package) for the app you want to upgrade.
It will be called com.barcodelogic.Imprest3.apk or similar.
Tap on it and follow the prompts to install it.

Delete Data

This will delete any scanned order data from the scanner. You will be asked if this is really
what you want to do.
Note that this does not delete the location/item or out of stock items lists.

About 

This function will display the version numbers of the hardware, firmware and software and the
serial number of the PDT.
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Settings

These options affect how the Scan Imprest function operates.
Scroll down to see all the settings.
This picture shows the recommended (and default) settings:

If Validate Data is on, then when a location or item barcode is scanned, the scanner will
check that it is a valid item and display an error if not.
If not on, any barcode can be scanned.
It is preferable to validate the scanned data as it reduces errors.

Validate Data has two sub-options:

Accept any valid item in any location
If you scan an item that is valid for the LHD but is not allocated in Oracle for the Imprest
Location (sub-inventory) currently being scanned, this option allows the item to be ordered
anyway, after a warning.

Allow entry of more than the Max Qty.
If the quantity entered is more than the maximum quantity for the item, the user will be
warned and asked to confirm that this is what they want to do, if this option is checked. 

The quantity entry options are:
Don't Enter a Qty: The scanner will order the Maximum order quantity for the item

irrespective of how many are still in stock.
Enter Qty Required: The operator enters how many they want to order.

Note that if the Validate Data option is not checked, the Max Quantity for the items scanned is
unknown and therefore an order quantity must be entered.

The three available combinations of these options cause the Scan Imprest function to operate
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in different ways, so we will explain each in turn:

Validate and Enter Qty Required
Validate and Don't Enter a Qty
Don't Validate Data

Use the touchscreen to change the options and press the Back button to save them and
exit.

 



Page40

ImprestCE2 User Guide V1.2.0                                                      

© Barcode Logic Pty Ltd, 2022

Scan Imprest

Validate and Enter Qty Required

How the scanning functions work depend on the Settings.
This is the most common, and default, method of operation. Validating the scanned barcodes
(check they are real items in Oracle) and enter the quantity you want to order. 

Firstly you will be prompted to enter the location code.
Either scan the location barcode or tap on the location field so the keyboard pops up,

manually key it and press 
The code may be up to 20 characters in length.

Pressing  at the location code prompt will return you to the main menu.
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After entering the location code, the scanner will check that the code is a valid location code
by searching for it in its data file.
If it is not found, an 'Invalid Location (not on file)' error will be displayed. Press OK to clear it
(See FAQ's for more information).
 
If the location code is found, you will be prompted to enter an item code:
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Either scan an item barcode or tap on the item field so the keyboard pops up, manually key it

and press 
After entering the item code, the scanner will check that the code is a valid item for the
current location by searching for it in its data file.
If it is not found, it will display an Invalid Item (not found on file for the current location)
error. Press OK to clear it and scan the next item.
Note: If the Accept any valid item in any location option is on in Settings it will accept it
and continue. see below.

Next, the scanner will check if the item is out of stock on the current date (see Out of Stock
Items).
If so, and the item has no substitute, you will be told, and you will not be able to order the
item.
If it is out of stock but there is a suggested substitute, you will be asked if you want to order
this item instead.
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The details of the item to be ordered will be displayed:

Type in the quantity required and press  or press  to close the keypad, then  to
cancel.
The scanner will return to the Item code prompt ready to scan the next item.

Note: You cannot enter a quantity greater than the m aximum order quantity for the item, in
this case, 1 unless the Allow entry of more than the Max Qty option is checked.
If you do, an 'Invalid Quantity' error will be displayed. Press OK to clear it.

Keep scanning items and entering quantities until the current location is finished, then press 

 to return to the location prompt to scan another location.

Pressing  at the location code prompt will return you to the main menu.

If you want to change the quantity ordered, delete an item, or want to know if you have
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already scanned an item, scan it again, a menu will appear:

Select Cancel if it was a mistake or you don't want to change anything.
Select Delete to delete the item from the list of scanned items.
Select Change Qty to change the quantity. You will be prompted to enter the new quantity:



Page45

ImprestCE2 User Guide V1.2.0                                                      

© Barcode Logic Pty Ltd, 2022

Enter the new quantity.
The scanner will then return to the item code prompt.

Accept any valid item in any location

If this option is checked in Settings and you scan an item that is not valid for the current
location, but is a valid item for your organisation (on file with a location of ALL_LHD_ITEMS), it
will be accepted.
Enter the quantity to order.

If it is not a valid item at all, an 'Invalid Item (not found on file)' error will be displayed.
Press OK to clear it.
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Validate and Don't Enter a Qty

If Enter Qty Required is NOT selected in Settings, you will not be prompted to enter an
order quantity.
The system will automatically order the Max quantity for that item in that location.

Firstly you will be prompted to enter the location code.
Either scan the location barcode or tap on the location field so the keyboard pops up,

manually key it and press 
The code may be up to 20 characters in length.

Pressing  at the location code prompt will return you to the main menu.
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After entering the location code, the scanner will check that the code is a valid location code
by searching for it in its data file.
If it is not found, an 'Invalid Location (not on file)' error will be displayed. Press OK to clear it
(See FAQ's for more information).
 
If the location code is found, you will be prompted to enter an item code:

Either scan an item barcode or tap on the item field so the keyboard pops up, manually key it

and press 
After entering the item code, the scanner will check that the code is a valid item for the
current location by searching for it in its data file.
If it is not found, it will display an Invalid Item (not found on file for the current location)
error. Press OK to clear it and scan the next item.
Note: If the Accept any valid item in any location option is on in Settings it will accept it
and continue. see below.

Next, the scanner will check if the item is out of stock on the current date (see Out of Stock
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Items).
If so, and the item has no substitute, you will be told, and you will not be able to order the
item.
If it is out of stock but there is a suggested substitute, you will be asked if you want to order
this item instead.

The details of the item to be ordered will be displayed:

The scanner will return to the Item code prompt ready to scan the next item.
Keep scanning items and entering quantities until the current location is finished, then press 

 to return to the location prompt to scan another location.

Pressing  at the location code prompt will return you to the main menu.

If you want to change the quantity ordered, delete an item, or want to know if you have
already scanned an item, scan it again, a menu will appear:
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Select Cancel if it was a mistake or you don't want to change anything.
Select Delete to delete the item from the list of scanned items.
Select Change Qty to change the quantity. You will be prompted to enter the new quantity:
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Enter the new quantity.
The scanner will then return to the item code prompt.

Accept any valid item in any location

If this option is checked in Settings and you scan an item that is not valid for the current
location, but is a valid item for your organisation (on file with a location of ALL_LHD_ITEMS), it
will be accepted.
Enter the quantity to order.

If it is not a valid item at all, an 'Invalid Item (not found on file)' error will be displayed.
Press OK to clear it.
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Don't Validate Data

Not validating the barcodes scanned is not recommended, but can be used in an emergency if
for some reason you have not beed able to get the list of valid item barcodes and locations
from Oracle into the scanner.
The problem with not validating is that invalid data will be rejected by Oracle when creating
requisitions, so you may not receive the equipment you expect.

If not validating against the item file you can scan any barcode in any location, then you will
have to enter a quantity to order for each item as there is no Maximum Quantity value.

Firstly you will be prompted to enter the location code.
Either scan the location barcode or tap on the location field so the keyboard pops up,

manually key it and press 
The code may be up to 20 characters in length.

Pressing  at the location code prompt will return you to the main menu.
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Any code can be entered, as there is no validation done against the data file.
After entering the location code, you will be prompted to enter an item code:
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Either scan an item barcode or tap on the item field so the keyboard pops up, manually key it

and press 
Any code can be entered, as there is no validation done against the data file.
It will also not check if the item is out of stock.
The scanner will prompt for the quantity required:
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Type in the quantity required and press  or press  to close the keypad, then  to
cancel.
No validation is done on the quantity entered as we do not know the Max Qty for the item.
The scanner will return to the Item code prompt ready to scan the next item.
Keep scanning items and entering quantities until the current location is finished, then press 

 to return to the location prompt to scan another location.

Pressing  at the location code prompt will return you to the main menu.

If you want to change the quantity ordered, delete an item, or want to know if you have
already scanned an item, scan it again, a menu will appear.
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Select Cancel if it was a mistake or you don't want to change anything.
Select Delete to delete the item from the list of scanned items.
Select Change Qty to change the quantity. You will be prompted to enter the new quantity.

Enter the new quantity.
The scanner will then return to the item code prompt.

 



Page58

ImprestCE2 User Guide V1.2.0                                                      

© Barcode Logic Pty Ltd, 2022

Frequently Asked Questions

Q. I forgot to scan something in a previous location. Can I go back and scan it now?
A. Yes, go back to the main menu, select Scan Imprest, scan the location then scan the item.

Q. I am not sure if I have already scanned an item. How can I find out?
A. If you are still in the same location, scan it again. If it has already been scanned in the
current location, the orange 'Item already scanned' window will appear. 
If you don't want to change anything, just press Cancel.
If the scanner is back at the main menu, select Scan Imprest, scan the location then scan the
item.  

Q. How do I change the order quantity for an item I have already scanned?
A. Scan it again, the 'Item already scanned' window will appear. Tap on Change Qty. 
Enter the new quantity.

Q. I scanned an item that I did not want to order. How do I delete it?
A. Scan it again, the 'Item already scanned' window will appear. Tap on Delete. 
It will ask you if you are sure you want to delete it.
Tap OK or Cancel..

Q. The scanner says 'Invalid Location (not on file)' what does this mean?
A. This will happen if Validate Data is checked in options, and the barcode scanned is not a
valid location barcode in the data file.
It may be that the barcode is damaged, or an item or other barcode was scanned accidentally.
If you believe it is a valid code, check that it exists in the database on the PC by looking for it
in Locations.
If you find it there, refresh the data in the scanner by using the Copy Imprest Data To
Scanner function.
If you do not find it there, check that the code is a valid location in Oracle.

Q.The scanner says 'Invalid Item (not found on file for this location)' what does this
mean?
A. This will happen if Validate Data is checked in options, and the barcode scanned is not a
valid item barcode for the current location.
It may be that the barcode is damaged, or a location or other barcode was scanned
accidentally.
If you believe it is a valid code, check that it exists in the database on the PC by looking for it
in Items.
If you find it there, refresh the data in the scanner by using the Copy Imprest Data To
Scanner function.
If you do not find it there, check that the code is a valid item for this location in Oracle.
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Load Imprest Data From Scanner To Oracle

When Imprest Scanning is complete, this function loads the data from the scanner to the PC
and prepares it for Import into Oracle.

To transfer the data, the scanner must be connected to the PC.
Place the scanner in its cradle.
The scanner should connect to the PC, and will make a distinctive noise to indicate it has
connected ok.

If it fails to connect, remove it from the cradle and replace it. If this fails, please refer to the
CE PDT Installation Guide for possible solutions.
Important: The scanner program must be at the main menu for the data file to upload
successfully. 

When connected, click on the Load Imprest Data From Scanner to Oracle button on the
main screen of the PC.

If Imprest data is found in the scanner, it will be copied to the PC and processed.

If the On upload from scanner, warn if the item has been ordered in the last nn
hours option is checked (See Setup Options), the program will check each item to see if it
has been recently ordered and a message displayed if so:

The options are these:
Yes: Order this item again - process it as though it had not been recently ordered.
No: Discard this new order.
No to All: Do not order this item or any subsequent items that have been ordered in the
previous nn hours (as configured in Options).
Yes to All: Process this and all subsequent items as normal, whether they have been ordered
in the previous nn hours or not.

The item order data is then imported into the local database, and a file created for Oracle to
import (stores.txt).
If a stores.txt file already exists, the new data will be appended at the end.

When complete, it will let you know ..
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If the option Automatically send Imprest Data to Oracle after upload from Scanner is
checked (see Setup Options) the system will then attempt to send the stores.txt file to Oracle.
If successful it will let you know .. 

The file (now called BL_IMPREST_STORES_REQ_nnn.nnn.nnn.nnn_yyyymmddhhmmss.dat)
will then be ready for Import into Oracle.
See Automatically send Imprest Data to Oracle for details.

Note: If for any reason it fails to transmit the stores.txt file to Oracle, an error will be
displayed and it will remain on the PC. 
You can attempt to send it again by clicking on the Load Imprest Data From Scanner to
Oracle button again. 
The system will attempt to get data from the scanner, which will probably fail as it has
already been uploaded, then attempt to send the file again.  

Technical Information:

The file in the scanner is called ImprestCE2.txt and can contain data from more than one
Imprest location (sub-inventory).
After copying to the PC, this raw data file is saved in the Barcode
Logic\ImprestCE2\Archive folder under the Windows common application data directory -
just as a backup. 
The date and time it was uploaded is contained in the filename.
Note: This file is not in the same format as stores.txt and cannot be directly substituted.

The file created for Import back into Oracle is called stores.txt (or Stores.txt depending on
the capital S option in Tools / Options).
The stores.txt file is created in the folder specified in the Imprest Export option in Tools /
Options.

The file has one record per item and is pipe | delimited. 
e.g.

321|102-RENAL WARD|500458|4|
321|102-RENAL WARD|500749|45|
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321|102-RENAL WARD|500750|8|
321|103-HUNTER BAILIE WD|500047|4|
321|103-HUNTER BAILIE WD|500151|3|
321|103-HUNTER BAILIE WD|500213|2|
321|103-HUNTER BAILIE WD|500245|1|

The fields are:
Organisation ID (as specified in Tools / Options)  
Location Code
Item Code
Order Quantity
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Automatically Send Imprest Data to Oracle

This function was added to eliminate the need to use the Oracle R12 Barcode Transfer Script
as it emulates everything the script does.

If the option Automatically send Imprest Data to Oracle after upload from Scanner is
checked (see Options) the system will attempt to send the stores.txt file to the Oracle FTP
Server.

The server settings (FTP server hostname, port, directory, username and password) can be
set in Tools > FTP Server Options from the main menu.
This option is password protected and the settings should not need to be changed but please
contact Barcode Logic if it is necessary.

If a stores.txt file exists in the Imprest Export File Path (see Options) it will be sent to the
Oracle FTP Server as:

BL_IMPREST_STORES_REQ_nnn.nnn.nnn.nnn_yyyymmddhhmmss.dat

where nnn.nnn.nnn.nnn is the IP Address of the Imprest System PC the file was sent from
and yyyymmddhhmmss is the date and time the file was sent.

If the file is successfully sent, the original stores.txt file is renamed to
BL_IMPREST_STORES_REQ_nnn.nnn.nnn.nnn_yyyymmddhhmmss.dat (the same as
the file sent to the FTP server).
It is then moved to the archive folder (C:\Users\Public\Documents\Barcode
Logic\Imprest3\Archive) on the Imprest System PC as a backup.

If necessary, for example if the data is lost before it is imported into Oracle, the file can be
sent again from the archive folder using the File > Resend Imprest Data to Oracle option
from the main menu.
Be careful if using this function as it can cause duplication of orders.
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Reports

This allows you to print a variety of reports listing the items ordered between a range of dates
by Item, by Location or for all items and locations.
The date range defaults to the last 7 days.

The reports looks similar to this:

The data shown on these reports is from the local database on the PC.
For absolute confirmation of what has been ordered, you should check in Oracle.
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Sales and Support

Contact Barcode Logic

Your first line of support will be your IT support team.

Should they be unable to help, please email any questions/suggestions to:

Barcode Logic
Tel: 02 43 910 148
EMail: info@barcodelogic.com.au
Web: www.barcodelogic.com.au

The Imprest3 software and this help file are (c) Copyright Barcode Logic Pty Ltd 1999-2022
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